Imbibition Saturation maximum percentage

· 3 · 1178
*

w_creig

  • *
  • Posts: 3
    • View Profile
Imbibition Saturation maximum percentage
« on: February 20, 2024, 10:22:29 AM »
Hi,

Whenever I run an imbibition simulation, the solver stops at around 70% saturation. Ideally, I would want 90-100% saturation to be achieved. What causes the solver to converge at a specific saturation? I can't disclose many details for confidentiality reasons.

*

Anne Blumer

  • Math2Market Employee
  • *****
  • Posts: 7
    • View Profile
    • Math2Market GmbH
  • Position: Application Engineer
Re: Imbibition Saturation maximum percentage
« Reply #1 on: February 21, 2024, 05:37:30 PM »
Hi,

thanks for posting this interesting question.
There are two settings in the Capillary Pressure options dialog that influence the final saturation of a structure.

1. In the Solver Parameters tab, check if Stop at Saturation is enabled.
This causes the simulation to stop if the entered saturation of the invading fluid is reached.
Solution: disable the option Stop at Saturation

2. In the Saturation Experiment tab, check if Displaced Fluid can leave a Residual is enabled.
With this option the displaced fluid that is not connected to the displaced fluid outlet stays inside the structure and leaves a residual.
Thus, the pore space cannot be completely filled with the invading fluid.
Is it desired to allow for the displaced fluid to leave a residual?
If not, the easiest solution is to disable the option Displaced Fluid can leave a Residual
If yes, changing the boundary conditions of the domain can improve the final saturation. Set Symmetric boundaries to Displaced Fluid Outlet. Then, the displaced fluid connected to these domain boundaries can leave the structure and reduces the remaining residual.

Does this help you?
Best regards
Anne

*

w_creig

  • *
  • Posts: 3
    • View Profile
Re: Imbibition Saturation maximum percentage
« Reply #2 on: February 26, 2024, 12:29:40 PM »
Hi Anne,

Thanks for the answer and apologies for the late response. I found out that unchecking "Replaced Fluid can leave a residual" (the second setting you listed) solved the problem. Thank you!